Rhino C++ API  8.11
Public Member Functions | Friends | List of all members
RhRdk::Realtime2::ChangeQueue::Skylight Class Referencefinal

#include <RhRdk_RCE_Queue2.h>

Public Member Functions

 Skylight (bool bOn, double dIntensity, bool bCustomEnvironment)
 
 Skylight (const IRhRdkSkylight &sl)
 
 Skylight (const Skylight &)=delete
 
 ~Skylight ()
 
bool CustomEnvironmentOn (void) const
 
bool On (void) const
 
const Skylightoperator= (const Skylight &)=delete
 
double ShadowIntensity (void) const
 

Friends

class Impl
 

Constructor & Destructor Documentation

◆ Skylight() [1/3]

RhRdk::Realtime2::ChangeQueue::Skylight::Skylight ( const IRhRdkSkylight sl)

◆ Skylight() [2/3]

RhRdk::Realtime2::ChangeQueue::Skylight::Skylight ( bool  bOn,
double  dIntensity,
bool  bCustomEnvironment 
)

◆ ~Skylight()

RhRdk::Realtime2::ChangeQueue::Skylight::~Skylight ( )

◆ Skylight() [3/3]

RhRdk::Realtime2::ChangeQueue::Skylight::Skylight ( const Skylight )
delete

Member Function Documentation

◆ CustomEnvironmentOn()

bool RhRdk::Realtime2::ChangeQueue::Skylight::CustomEnvironmentOn ( void  ) const

true if skylight uses a custom environment.

◆ On()

bool RhRdk::Realtime2::ChangeQueue::Skylight::On ( void  ) const

true if skylight is active.

◆ operator=()

const Skylight& RhRdk::Realtime2::ChangeQueue::Skylight::operator= ( const Skylight )
delete

◆ ShadowIntensity()

double RhRdk::Realtime2::ChangeQueue::Skylight::ShadowIntensity ( void  ) const

the shadow intensity for skylight.

Friends And Related Function Documentation

◆ Impl

friend class Impl
friend