Rhino C++ API  8.11
Public Member Functions | Friends | List of all members
RhRdk::Realtime2::ChangeQueue::ClippingPlane Class Referencefinal

#include <RhRdk_RCE_Queue2.h>

Public Member Functions

 ClippingPlane (const ClippingPlane &)=delete
 
 ClippingPlane (const RhRdk::Realtime2::ChangeQueue &queue, const ON_ClippingPlane &cp, const ON_UUID &objectId)
 
 ~ClippingPlane (void)
 
const ON_ClippingPlaneClippingPlaneData () const
 
const CRhinoClippingPlaneObjectObject (void) const
 
const ClippingPlaneoperator= (const ClippingPlane &)=delete
 

Friends

class Impl
 

Constructor & Destructor Documentation

◆ ClippingPlane() [1/2]

RhRdk::Realtime2::ChangeQueue::ClippingPlane::ClippingPlane ( const ClippingPlane )
delete

◆ ClippingPlane() [2/2]

RhRdk::Realtime2::ChangeQueue::ClippingPlane::ClippingPlane ( const RhRdk::Realtime2::ChangeQueue queue,
const ON_ClippingPlane cp,
const ON_UUID objectId 
)

◆ ~ClippingPlane()

RhRdk::Realtime2::ChangeQueue::ClippingPlane::~ClippingPlane ( void  )

Member Function Documentation

◆ ClippingPlaneData()

const ON_ClippingPlane& RhRdk::Realtime2::ChangeQueue::ClippingPlane::ClippingPlaneData ( ) const

Get the ON_ClippingPlane&

◆ Object()

const CRhinoClippingPlaneObject* RhRdk::Realtime2::ChangeQueue::ClippingPlane::Object ( void  ) const

Get the CRhinoClippingPlaneObject*. (useful in case you have user data attached to it. )

◆ operator=()

const ClippingPlane& RhRdk::Realtime2::ChangeQueue::ClippingPlane::operator= ( const ClippingPlane )
delete

Friends And Related Function Documentation

◆ Impl

friend class Impl
friend