Rhino C++ API  8.11
Public Member Functions | Public Attributes | List of all members
RhEdgeSofteningArgs Class Reference

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhEdgeSofteningArgs ()
 The constructor sets the default values of the arguments. More...
 

Public Attributes

bool m_bChamfer
 Specifies whether to chamfer the edges. More...
 
bool m_bFaceted
 Specifies whether the edges are faceted. More...
 
bool m_bForceSoftening
 Specifies whether to soften edges despite too large a radius. More...
 
double m_dEdgeAngleThreshold
 
double m_dSoftening
 The softening radius. More...
 

Detailed Description

Description: Contains the arguments to the RhinoEdgeSoftenMesh function.

Constructor & Destructor Documentation

◆ RhEdgeSofteningArgs()

RhEdgeSofteningArgs::RhEdgeSofteningArgs ( )

The constructor sets the default values of the arguments.

Member Data Documentation

◆ m_bChamfer

bool RhEdgeSofteningArgs::m_bChamfer

Specifies whether to chamfer the edges.

◆ m_bFaceted

bool RhEdgeSofteningArgs::m_bFaceted

Specifies whether the edges are faceted.

◆ m_bForceSoftening

bool RhEdgeSofteningArgs::m_bForceSoftening

Specifies whether to soften edges despite too large a radius.

◆ m_dEdgeAngleThreshold

double RhEdgeSofteningArgs::m_dEdgeAngleThreshold

Threshold angle (in degrees) which controls whether an edge is softened or not. The angle refers to the angles between the adjacent faces of an edge.

◆ m_dSoftening

double RhEdgeSofteningArgs::m_dSoftening

The softening radius.