Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDVertexSurfacePointCoefficient Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDVertexSurfacePointCoefficient ()=default
 
 ON_SubDVertexSurfacePointCoefficient (const ON_SubDVertexSurfacePointCoefficient &)=default
 
 ~ON_SubDVertexSurfacePointCoefficient ()=default
 
double Coefficient () const
 
ON_SubDVertexSurfacePointCoefficientoperator= (const ON_SubDVertexSurfacePointCoefficient &)=default
 
unsigned int RingVertexId () const
 
unsigned int SurfacePointVertexId () const
 

Static Public Member Functions

static int CompareRingAndSurfacePointVertexId (const ON_SubDVertexSurfacePointCoefficient *lhs, const ON_SubDVertexSurfacePointCoefficient *rhs)
 
static int CompareRingVertexId (const ON_SubDVertexSurfacePointCoefficient *lhs, const ON_SubDVertexSurfacePointCoefficient *rhs)
 
static int CompareSurfacePointAndRingVertexId (const ON_SubDVertexSurfacePointCoefficient *lhs, const ON_SubDVertexSurfacePointCoefficient *rhs)
 
static int CompareSurfacePointVertexId (const ON_SubDVertexSurfacePointCoefficient *lhs, const ON_SubDVertexSurfacePointCoefficient *rhs)
 
static const ON_SubDVertexSurfacePointCoefficient Create (const ON_SubDVertex *limit_point_vertex, const ON_SubDVertex *ring_vertex, double x)
 
static bool GetSurfacePointLinearSystemMatrix (unsigned int vertex_count, const ON_SimpleArray< ON_SubDVertexSurfacePointCoefficient > &coefficients, ON_Matrix &m, ON_SimpleArray< const ON_SubDVertex * > &v)
 
static bool TestCoefficients (const ON_Matrix &m, const ON_SimpleArray< const ON_SubDVertex * > &v, double deviation_tolerance, double &maximum_deviation, unsigned int &failed_coefficient_index, ON_TextLog &text_log)
 
static bool TestCoefficients (const ON_SimpleArray< ON_SubDVertexSurfacePointCoefficient > &coefficients, double deviation_tolerance, double &maximum_deviation, unsigned int &failed_coefficient_index, ON_TextLog &text_log)
 

Public Attributes

double m_c = 0.0
 
const ON_SubDVertexm_limit_point_vertex = nullptr
 
const ON_SubDVertexm_ring_vertex = nullptr
 

Static Public Attributes

static const ON_SubDVertexSurfacePointCoefficient Nan
 ON_SubDVertexSurfacePointCoefficient::Nan.m_c = ON_DBL_QNAN. More...
 
static const ON_SubDVertexSurfacePointCoefficient Unset
 ON_SubDVertexSurfacePointCoefficient::Unset.m_c = ON_UNSET_VALUE. More...
 
static const ON_SubDVertexSurfacePointCoefficient Zero
 ON_SubDVertexSurfacePointCoefficient::Zero.m_c = 0.0. More...