Rhino C++ API  8.10
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDVertexEdgeProperties Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDVertexEdgeProperties ()=default
 
 ON_SubDVertexEdgeProperties (const ON_SubDVertexEdgeProperties &)=default
 
 ~ON_SubDVertexEdgeProperties ()=default
 
unsigned EdgeCount () const
 
bool HasBoundaryVertexTopology () const
 
bool HasInteriorVertexTopology () const
 
bool HasManifoldVertexTopology () const
 
bool HasNonmanifoldVertexTopology () const
 
ON_SubDVertexEdgePropertiesoperator= (const ON_SubDVertexEdgeProperties &)=default
 

Public Attributes

unsigned short m_boundary_edge_count = 0
 Number of boundary edges (1 attached face) More...
 
unsigned short m_crease_edge_count = 0
 Number of edges tags ON_SubDEdgeTag::Crease. More...
 
unsigned short m_edge_count = 0
 vertex->m_edge_count More...
 
unsigned short m_face_count = 0
 vertex->m_face_count More...
 
unsigned short m_interior_edge_count = 0
 Number of interior edges (2 attached faces) More...
 
unsigned short m_max_edge_face_count = 0
 Maximum value of attached edges's m_face_count. More...
 
unsigned short m_min_edge_face_count = 0
 Minimum value of attached edges's m_face_count. More...
 
unsigned short m_nonmanifold_edge_count = 0
 Number of nonmanifold edges (3 or more attached faces) More...
 
unsigned short m_null_edge_count = 0
 Number of null edges. More...
 
unsigned short m_smooth_edge_count = 0
 Number of edges tags ON_SubDEdgeTag::Smooth or ON_SubDEdgeTag::SmoothX. More...
 
unsigned short m_unset_edge_count = 0
 Number of edges tags ON_SubDEdgeTag::Unset. More...
 
unsigned short m_wire_edge_count = 0
 Number of wire edges (0 attached faces) More...
 

Static Public Attributes

static const ON_SubDVertexEdgeProperties Zero
 all member values are zero. More...
 

Detailed Description

ON_SubDVertexEdgeProperties