Rhino C++ API  8.10
Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ON_SubDToBrepParameters Class Reference

#include <opennurbs_subd.h>

Public Types

enum  VertexProcess : unsigned char {
  VertexProcess::None = 0, VertexProcess::LocalG1 = 1, VertexProcess::LocalG2 = 2, VertexProcess::LocalG1x = 3,
  VertexProcess::LocalG1xx = 4
}
 ON_SubDToBrepParameters::Vertex identifies the options for post processing extraorindary vertices. More...
 

Public Member Functions

 ON_SubDToBrepParameters ()=default
 
 ON_SubDToBrepParameters (const ON_SubDToBrepParameters &)=default
 
 ~ON_SubDToBrepParameters ()=default
 
ON_SubDToBrepParameters::VertexProcess ExtraordinaryVertexProcess () const
 
ON_SubDToBrepParametersoperator= (const ON_SubDToBrepParameters &)=default
 
bool PackFaces () const
 
bool Read (ON_BinaryArchive &archive)
 
void SetExtraordinaryVertexProcess (ON_SubDToBrepParameters::VertexProcess ev_process)
 
void SetPackFaces (bool bPackFaces)
 
const ON_wString ToString (bool bVerbose) const
 
bool Write (ON_BinaryArchive &archive) const
 

Static Public Member Functions

static int Compare (const ON_SubDToBrepParameters &lhs, const ON_SubDToBrepParameters &rhs)
 
static int CompareFromPointers (const ON_SubDToBrepParameters *lhs, const ON_SubDToBrepParameters *rhs)
 
static ON_SubDToBrepParameters::VertexProcess VertexProcessFromUnsigned (unsigned int vertex_process_as_unsigned)
 
static const ON_wString VertexProcessToString (ON_SubDToBrepParameters::VertexProcess vertex_process)
 

Static Public Attributes

static const ON_SubDToBrepParameters Default
 
static const ON_SubDToBrepParameters DefaultPacked
 
static const ON_SubDToBrepParameters DefaultUnpacked