Rhino C++ API  8.10
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDSectorSurfacePoint Class Reference

#include <opennurbs_subd.h>

Public Member Functions

bool IsNan () const
 
bool IsSet (bool bUndefinedNormalIsPossible) const
 
bool IsUnset () const
 
bool IsZero () const
 
const ON_3dVector Normal () const
 Get a limit surface normal. More...
 
const ON_3dPoint Point () const
 Get a limit surface point. More...
 
const ON_3dVector Tangent (int tangent_index) const
 Get a limit surface tangent vector. More...
 
bool Transform (const ON_Xform &xform)
 
bool Transform (const ON_Xform &xform, const ON_Xform &xformNormals)
 

Public Attributes

double m_limitN [3]
 unit normal (same direction as m_limitT1 x m_limitT2) More...
 
double m_limitP [3]
 limit surface point, tangents and normal More...
 
double m_limitT1 [3]
 first unit tangent More...
 
double m_limitT2 [3]
 second unit tangent More...
 
const class ON_SubDSectorSurfacePointm_next_sector_limit_point
 nullptr for vertices with one sector More...
 
const class ON_SubDFacem_sector_face
 nullptr for vertices with one sector More...
 

Static Public Attributes

static const ON_SubDSectorSurfacePoint Nan
 all doubles are ON_DBL_QNAN, all pointer are nullptr More...
 
static const ON_SubDSectorSurfacePoint Unset
 all doubles are ON_UNSET_VALUE, all pointer are nullptr More...
 
static const ON_SubDSectorSurfacePoint Zero
 all doubles are 0.0, all pointer are nullptr More...