Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Static Public Attributes | Friends | List of all members
ON_SubDMesh Class Reference

ON_SubDMesh is used to store a high density traditional quad mesh of a SubD surface or a mesh of a SubD control net. In general, is is better to use an ON_SubDMeshFragmentIterator(subd) that iterates the ON_MeshFragments cached on the ON_SubD. More...

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDMesh ()=default
 
 ON_SubDMesh (const ON_SubDMesh &)=default
 
 ~ON_SubDMesh ()=default
 
unsigned int AbsoluteSubDDisplayDensity () const
 
ON_BoundingBox BoundingBox () const
 
void Clear ()
 
void ClearTree ()
 
ON__UINT64 ContentSerialNumber () const
 
ON_SubDMesh Copy () const
 
ON_SubDMeshCopyFrom (const ON_SubDMesh &src)
 
unsigned int DisplayDensity () const
 
ON_SubDDisplayParameters DisplayParameters () const
 
const ON_SubDMeshFragmentFaceFragment (const class ON_SubDFace *face) const
 
const ON_SubDMeshFragmentFirstFragment () const
 linked list of mesh fragments More...
 
unsigned int FragmentCount () const
 
const ON_RTreeFragmentTree () const
 
bool GetEdgeCenterPointAndNormal (const class ON_SubDEdge *edge, unsigned int edge_face_index, double *P, double *N) const
 
bool GetFaceCenterPointAndNormal (const class ON_SubDFace *face, double *P, double *N) const
 
bool GetTightBoundingBox (ON_BoundingBox &bbox, bool bGrowBox, const ON_Xform *xform) const
 
bool IsEmpty () const
 
ON_SubDMeshoperator= (const ON_SubDMesh &)=default
 
ON_SubD SubD () const
 
ON_SubDRef SubDRef () const
 
class ON_SubDMeshImplSubLimple () const
 
unsigned int SubLimpleUseCount () const
 
ON_MeshToMesh (ON_Mesh *destination_mesh) const
 
ON_MeshToMesh (unsigned int mesh_density, ON_Mesh *destination_mesh) const
 
bool Transform (bool bKeepCurvatures, bool bKeepTextures, bool bKeepColors, const ON_Xform &xform, const ON_Xform &xformNormals, const ON_Xform &xformCurvatures, const ON_Xform &xformTextures, const ON_Xform &xformColors)
 
bool Transform (const ON_Xform &xform)
 
bool Update (bool bShareUpdate)
 

Static Public Member Functions

static ON_SubDMeshCreate (const ON_SubD &subd, const class ON_SubDDisplayParameters &limit_mesh_parameters, ON_SubDMesh *destination_mesh)
 
static ON_SubDMeshCreate (ON_SubDFaceIterator fit, const class ON_SubDDisplayParameters &limit_mesh_parameters, ON_SubDMesh *destination_mesh)
 
static void Swap (ON_SubDMesh &a, ON_SubDMesh &b)
 
static ON_MeshToMesh (class ON_SubDMeshFragmentIterator &frit, unsigned int mesh_density, ON_Mesh *destination_mesh)
 

Static Public Attributes

static const ON_SubDMesh Empty
 

Friends

class ON_SubDMeshImpl
 

Detailed Description

ON_SubDMesh is used to store a high density traditional quad mesh of a SubD surface or a mesh of a SubD control net. In general, is is better to use an ON_SubDMeshFragmentIterator(subd) that iterates the ON_MeshFragments cached on the ON_SubD.

ON_SubDMesh