Rhino C++ API  8.10
Public Types | Public Member Functions | Static Public Attributes | List of all members
ON_SubDFromSurfaceParameters Class Reference

#include <opennurbs_subd.h>

Public Types

enum  Methods : unsigned char { Methods::Unset = 0, Methods::SubDFriendlyFit = 1, Methods::FromNurbsControlNet = 2 }
 ON_SubDFromSurfaceParameters::Method are ways to create a SubD from a surface. More...
 

Public Member Functions

 ON_SubDFromSurfaceParameters ()=default
 Default construction is identical to ON_SubDFromMeshParameters::Smooth. More...
 
 ON_SubDFromSurfaceParameters (const ON_SubDFromSurfaceParameters &)=default
 
 ~ON_SubDFromSurfaceParameters ()=default
 
bool Corners () const
 
ON_SubDFromSurfaceParameters::Methods Method () const
 
ON_SubDFromSurfaceParametersoperator= (const ON_SubDFromSurfaceParameters &)=default
 
void SetCorners (bool bCorners)
 
void SetMethod (ON_SubDFromSurfaceParameters::Methods method)
 

Static Public Attributes

static const ON_SubDFromSurfaceParameters ControlNet
 
static const ON_SubDFromSurfaceParameters ControlNetWithCorners
 
static const ON_SubDFromSurfaceParameters Default
 
static const ON_SubDFromSurfaceParameters DefaultWithCorners
 

Detailed Description

ON_SubDFromMeshParameters