Rhino C++ API  8.11
Public Member Functions | Protected Member Functions | List of all members
IRhRdkPostEffectThreadEngine::IJob::IChannels Class Referenceabstract

#include <RhRdkNewPostEffectPlugIn.h>

Public Member Functions

virtual void * EVF (const wchar_t *, void *)=0
 
virtual IRhRdkPostEffectPipeline::IChannelGetChannel (const UUID &chanId) const =0
 

Protected Member Functions

virtual ~IChannels ()
 

Detailed Description

This is a collection of channels that will be processed by the post effect. The channels in this collection are copies of some of the channels being passed through the post effect pipeline. These are the channels that were specified by id during the call to RunPostEffect(). The post effect will read from one or more of these channels, do calculations, and write the results to one or more of the channels.

Constructor & Destructor Documentation

◆ ~IChannels()

virtual IRhRdkPostEffectThreadEngine::IJob::IChannels::~IChannels ( )
inlineprotectedvirtual

Member Function Documentation

◆ EVF()

virtual void* IRhRdkPostEffectThreadEngine::IJob::IChannels::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ GetChannel()

virtual IRhRdkPostEffectPipeline::IChannel* IRhRdkPostEffectThreadEngine::IJob::IChannels::GetChannel ( const UUID &  chanId) const
pure virtual

Get a channel interface. This interface can be used to get the channel data.

Parameters
chanIdis the channel identifier.
Returns
a pointer to the channel or null if the channel is not in the collection.