Rhino C++ API
8.17
|
#include <RhinoSdkUiProgressCtrl.h>
Public Types | |
enum | display_mode { display_test = 1, display_percent = 2, display_text_and_percent = 3, force_32bit_display_mode = 0xFFFFFFFF } |
Public Member Functions | |
CRhinoUiProgressCtrl () | |
virtual | ~CRhinoUiProgressCtrl () |
COLORREF | GetBkColor () |
Sets the text visibility. More... | |
COLORREF | GetForeColor () |
Get an set the background color. More... | |
CString | GetText () |
Advances the current position by a specified increment. More... | |
COLORREF | GetTextBkColor () |
Get an set the foreground color. More... | |
COLORREF | GetTextForeColor () |
Get an set the text background color. More... | |
int | OffsetPos (int nPos) |
Advances the current position by a step. More... | |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
afx_msg LRESULT | OnGetText (WPARAM, LPARAM) |
afx_msg void | OnPaint () |
afx_msg LRESULT | OnSetText (WPARAM, LPARAM) |
afx_msg void | OnSize (UINT nType, int cx, int cy) |
void | SetBkColor (COLORREF cf) |
void | SetForeColor (COLORREF cf) |
int | SetPos (int nPos) |
Sets the step increment. More... | |
void | SetRange (int nLower, int nUpper) |
void | SetShowStyle (int nStyle) |
Sets the text font. More... | |
void | SetShowText (bool bShow) |
Sets the text display style. More... | |
int | SetStep (int nStep) |
Sets the lower and upper range. More... | |
void | SetText (LPCTSTR lpText) |
void | SetTextBkColor (COLORREF cf) |
BOOL32 | SetTextFont (const LOGFONT &lf) |
Gets and sets the text. More... | |
void | SetTextForeColor (COLORREF cf) |
int | StepIt () |
Sets the position. More... | |
Protected Attributes | |
bool | m_bShowText |
Text visibility. More... | |
COLORREF | m_cfBackground |
Background color. More... | |
COLORREF | m_cfForeground |
Foreground color. More... | |
COLORREF | m_cfTextBackground |
Text background color. More... | |
COLORREF | m_cfTextForeground |
Text foreground color. More... | |
CFont | m_Font |
Text font. More... | |
int | m_nBarWidth |
Vidth of the progress bar. More... | |
int | m_nMax |
Maximum range value. More... | |
int | m_nMin |
Minimum range value. More... | |
int | m_nPos |
Current position. More... | |
int | m_nShowStyle |
Text show style. More... | |
int | m_nStepSize |
Step increment. More... | |
CString | m_strText |
Progress bar text. More... | |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiProgressCtrl::CRhinoUiProgressCtrl | ( | ) |
|
virtual |
|
inline |
Sets the text visibility.
|
inline |
Get an set the background color.
|
inline |
Advances the current position by a specified increment.
|
inline |
Get an set the foreground color.
|
inline |
Get an set the text background color.
int CRhinoUiProgressCtrl::OffsetPos | ( | int | nPos | ) |
Advances the current position by a step.
afx_msg BOOL32 CRhinoUiProgressCtrl::OnEraseBkgnd | ( | CDC * | pDC | ) |
afx_msg void CRhinoUiProgressCtrl::OnPaint | ( | ) |
afx_msg void CRhinoUiProgressCtrl::OnSize | ( | UINT | nType, |
int | cx, | ||
int | cy | ||
) |
|
inline |
|
inline |
int CRhinoUiProgressCtrl::SetPos | ( | int | nPos | ) |
Sets the step increment.
void CRhinoUiProgressCtrl::SetRange | ( | int | nLower, |
int | nUpper | ||
) |
void CRhinoUiProgressCtrl::SetShowStyle | ( | int | nStyle | ) |
Sets the text font.
void CRhinoUiProgressCtrl::SetShowText | ( | bool | bShow | ) |
Sets the text display style.
int CRhinoUiProgressCtrl::SetStep | ( | int | nStep | ) |
Sets the lower and upper range.
void CRhinoUiProgressCtrl::SetText | ( | LPCTSTR | lpText | ) |
|
inline |
|
inline |
int CRhinoUiProgressCtrl::StepIt | ( | ) |
Sets the position.
|
protected |
Text visibility.
|
protected |
Background color.
|
protected |
Foreground color.
|
protected |
Text background color.
|
protected |
Text foreground color.
|
protected |
Text font.
|
protected |
Vidth of the progress bar.
|
protected |
Maximum range value.
|
protected |
Minimum range value.
|
protected |
Current position.
|
protected |
Text show style.
|
protected |
Step increment.
|
protected |
Progress bar text.