Rhino C++ API
8.17
|
CRhinoUiPrintWidthListCtrl. More...
#include <RhinoSdkUiPrintWidthListCtrl.h>
Public Types | |
enum | columns { name_column = 0, appearance_column, column_count } |
Public Member Functions | |
CRhinoUiPrintWidthListCtrl () | |
virtual | ~CRhinoUiPrintWidthListCtrl () |
int | AppendPrintWidth (double print_width) |
ON::LengthUnitSystem | DisplayUnits () const |
int | FindPrintWidth (double print_width) const |
void | Initialize () |
int | InsertPrintWidth (int item, double print_width) |
afx_msg void | OnCustomDraw (NMHDR *pNMHDR, LRESULT *pResult) |
afx_msg void | OnHeaderEndTrack (NMHDR *pNMHDR, LRESULT *pResult) |
afx_msg void | OnSize (UINT nType, int cx, int cy) |
bool | SelectedPrintWidth (double &print_width) |
void | SetDisplayUnits (ON::LengthUnitSystem display_units) |
void | SetSelectedPrintWidth (double print_width) |
void | SizeAppearanceColumn () |
void | SizeNameColumn () |
Protected Member Functions | |
virtual BOOL32 | PreCreateWindow (CREATESTRUCT &cs) |
virtual void | PreSubclassWindow () |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiPrintWidthListCtrl::CRhinoUiPrintWidthListCtrl | ( | ) |
|
virtual |
int CRhinoUiPrintWidthListCtrl::AppendPrintWidth | ( | double | print_width | ) |
Description: Appends a print width to the end of the control. Parameters: print_width - [in] the print width to append. Returns: >=0 - index of the inserted item. -1 - print_width already exist.
ON::LengthUnitSystem CRhinoUiPrintWidthListCtrl::DisplayUnits | ( | ) | const |
Description: Returns the current display unit system. Returns: The current display unit system. See Also: SetDisplayUnits
int CRhinoUiPrintWidthListCtrl::FindPrintWidth | ( | double | print_width | ) | const |
Description: Finds a print width that is displayed in the control. Parameters: print_width - [in] the print width to find. Returns: >=0 - index of the item. -1 - print width cannot be found.
void CRhinoUiPrintWidthListCtrl::Initialize | ( | ) |
Description: Initializes the control. Remarks: Call this member from CDialog::OnInitDialog().
int CRhinoUiPrintWidthListCtrl::InsertPrintWidth | ( | int | item, |
double | print_width | ||
) |
Description: Inserts a print width into the control. Parameters: item - [in] index of the item to insert. print_width - [in] the print width to insert. Returns: >=0 - index of the inserted item. -1 - print_width already exist.
afx_msg void CRhinoUiPrintWidthListCtrl::OnCustomDraw | ( | NMHDR * | pNMHDR, |
LRESULT * | pResult | ||
) |
afx_msg void CRhinoUiPrintWidthListCtrl::OnHeaderEndTrack | ( | NMHDR * | pNMHDR, |
LRESULT * | pResult | ||
) |
afx_msg void CRhinoUiPrintWidthListCtrl::OnSize | ( | UINT | nType, |
int | cx, | ||
int | cy | ||
) |
|
protectedvirtual |
|
protectedvirtual |
bool CRhinoUiPrintWidthListCtrl::SelectedPrintWidth | ( | double & | print_width | ) |
Description: Returns the selected print width. Parameters: print_width - [out] the print width to retrieve. Returns: TRUE - if an item is selected. FALSE - if an item is not selected.
void CRhinoUiPrintWidthListCtrl::SetDisplayUnits | ( | ON::LengthUnitSystem | display_units | ) |
Description: Sets the current display unit system. Parameters: display_units - [in] the units system. The default is ON::LengthUnitSystem::None. See Also: DisplayUnits
void CRhinoUiPrintWidthListCtrl::SetSelectedPrintWidth | ( | double | print_width | ) |
Description: Selects print width that exists in the control. Parameters: print_width - [in] the print width to select.
void CRhinoUiPrintWidthListCtrl::SizeAppearanceColumn | ( | ) |
Description: Automatically sizes the appearance column.
void CRhinoUiPrintWidthListCtrl::SizeNameColumn | ( | ) |
Description: Automatically sizes the name column.