Rhino C++ API
8.17
|
#include <RhinoSkdUiFontComboBox.h>
Public Member Functions | |
CRhinoUiFontComboBox () | |
virtual | ~CRhinoUiFontComboBox () |
virtual int | CompareItem (LPCOMPAREITEMSTRUCT) |
virtual void | DrawItem (LPDRAWITEMSTRUCT) |
void | FillFonts (char *focus) |
void | FillFonts (wchar_t *focus=NULL) |
int | GetFontListIndex (const char *lpsFontFaceName) |
int | GetFontListIndex (const wchar_t *lpsFontFaceName) |
LOGFONT * | GetLogfontFromListIndex (int index) |
int | GetSelFont (LOGFONT &) |
bool | IgnoreZeroTypeFonts () const |
virtual void | MeasureItem (LPMEASUREITEMSTRUCT) |
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct) |
afx_msg void | OnDestroy () |
bool | OnlyShowTrueTypeFonts () const |
void | SetHilightColors (COLORREF hilight, COLORREF hilightText) |
bool | SetIgnoreZeroTypeFonts (bool value) |
void | SetNormalColors (COLORREF clrBkgnd, COLORREF clrText) |
bool | SetOnlyShowTrueTypeFonts (bool b) |
void | SetVaries (bool b) |
bool | Varies () |
Public Attributes | |
CPtrArray | m_font_list |
Protected Member Functions | |
int | _GetFontListIndex (LPCTSTR lpsFontFaceName) |
void | DrawDefault (LPDRAWITEMSTRUCT) |
void | DrawFont (LPDRAWITEMSTRUCT) |
void | InitFonts () |
Protected Attributes | |
bool | m_bInitOver |
bool | m_bTrueTypeOnly |
bool | m_bVaries |
Added varies support 8/2/07 LW. More... | |
COLORREF | m_clrBkgnd |
COLORREF | m_clrHilight |
COLORREF | m_clrHilightText |
COLORREF | m_clrNormalText |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiFontComboBox::CRhinoUiFontComboBox | ( | ) |
|
virtual |
|
protected |
|
virtual |
|
protected |
|
protected |
|
virtual |
void CRhinoUiFontComboBox::FillFonts | ( | char * | focus | ) |
void CRhinoUiFontComboBox::FillFonts | ( | wchar_t * | focus = NULL | ) |
int CRhinoUiFontComboBox::GetFontListIndex | ( | const char * | lpsFontFaceName | ) |
int CRhinoUiFontComboBox::GetFontListIndex | ( | const wchar_t * | lpsFontFaceName | ) |
LOGFONT* CRhinoUiFontComboBox::GetLogfontFromListIndex | ( | int | index | ) |
int CRhinoUiFontComboBox::GetSelFont | ( | LOGFONT & | ) |
bool CRhinoUiFontComboBox::IgnoreZeroTypeFonts | ( | ) | const |
|
protected |
|
virtual |
afx_msg int CRhinoUiFontComboBox::OnCreate | ( | LPCREATESTRUCT | lpCreateStruct | ) |
afx_msg void CRhinoUiFontComboBox::OnDestroy | ( | ) |
bool CRhinoUiFontComboBox::OnlyShowTrueTypeFonts | ( | ) | const |
bool CRhinoUiFontComboBox::SetIgnoreZeroTypeFonts | ( | bool | value | ) |
bool CRhinoUiFontComboBox::SetOnlyShowTrueTypeFonts | ( | bool | b | ) |
void CRhinoUiFontComboBox::SetVaries | ( | bool | b | ) |
bool CRhinoUiFontComboBox::Varies | ( | ) |
|
protected |
|
protected |
|
protected |
Added varies support 8/2/07 LW.
|
protected |
|
protected |
|
protected |
|
protected |
CPtrArray CRhinoUiFontComboBox::m_font_list |