Rhino C++ API
8.17
|
#include <RhRdkContentEditorCustomButtonProvider.h>
Public Types | |
enum | Style : unsigned int { Style::Simple = 0, Style::Flat = 1, Style::FlatPopup = 2 } |
Public Member Functions | |
virtual bool | ButtonDetails (int iIndex, CRhRdkContent::Kinds kind, CRhinoDib &dibOut, ON_wString &sCaptionOut, ON_wString &sToolTipOut, int &iWidthOut, int &iGapOut, COLORREF &colBackOut, Style &styleOut, DWORD &dwFlagsOut, DWORD_PTR reserved) const =0 |
virtual int | ButtonHeight (void) const =0 |
virtual UUID | InterfaceId (void) const final override |
virtual int | LeftMargin (void) const =0 |
virtual bool | OnButtonClicked (int index)=0 |
virtual UUID | RenderEngineID (void) const =0 |
![]() | |
CRhRdkExtension () | |
virtual | ~CRhRdkExtension () |
virtual UUID | PlugInId (void) const =0 |
bool | Unregister (void) |
![]() | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
![]() | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This class allows a client to add custom buttons to the bottom of content editor windows. You can implement the abstract interface to provide custom buttons on the content editors.
|
strong |
|
pure virtual |
Implement this method to describe your custom buttons. For each content kind, RDK sets iIndex to zero and calls this method continually increasing iIndex until it returns false.
iIndex | is the button index starting at zero and increasing with each call. |
kind | is the kind of content being displayed in the associated editor. |
dibOut | accepts the button's imagery (or 'icon'). If an icon is not required, do not set this parameter. |
sCaptionOut | accepts the button's caption. If a caption is not required, do not set this parameter. |
sToolTipOut | accepts the button's tool-tip. If a tool-tip is not required, do not set this parameter. |
iWidthOut | accepts the button's width. If you do not set this parameter, the width will be 23 pixels. |
iGapOut | accepts the gap after the button. If you do not set this parameter, the gap will be 2 pixels. |
colBackOut | is the button's background color. If a special color is not required, do not set this parameter. |
styleOut | specifies the button style. |
dwFlagsOut | is currently unused. |
reserved | is reserved for future use. |
|
pure virtual |
Implement this method to return the height of your custom buttons.
|
finaloverridevirtual |
Returns the unique interface id of this extension.
Implements CRhRdkExtension.
|
pure virtual |
Implement this method to return the left margin before the first button.
|
pure virtual |
Implement this method to handle a button click.
index | is the index of the button that was clicked. |
|
pure virtual |
Implement this method to return your render engine's id.