Tracing Class |
Namespace: Grasshopper
The Tracing type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | Assert(Guid) |
Display a typical ASSERT dialog with stack information.
|
![]() ![]() | Assert(Guid, Exception) |
Display a typical assert dialog with stack information.
|
![]() ![]() | Assert(Guid, String) |
Display a typical assert dialog with stack information.
|
![]() ![]() | Assert(Guid, String, Exception) |
Display a typical assert dialog with stack information.
|
![]() ![]() | DebugLogAddEntry |
Add a message to the debug log. If the debug log doesn't exist yet, it will be created.
This function will only work if the Grasshopper window exists. This method is threadsafe.
|
![]() ![]() | DebugLogBeginBlock |
Start a new block in the debug data. You must end all your own blocks.
This function will only work if the Grasshopper window exists. This method is threadsafe.
|
![]() ![]() | DebugLogEndBlock |
Start a new block in the debug data. You must end all your own blocks.
This function will only work if the Grasshopper window exists. This method is threadsafe.
|