IGH_UndoAction Interface |
Namespace: Grasshopper.Kernel.Undo
The IGH_UndoAction type exposes the following members.
Name | Description | |
---|---|---|
ExpiresDisplay |
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn
once the entire undo record has been completed.
If ExpiresSolution is set to true, ExpriresDisplay is implied.
| |
ExpiresSolution |
Gets the solution expiration flag for this event.
If True, the solution needs to be recalculated once the entire undo record has been completed.
| |
State |
Gets the current state of the undo action.
|
Name | Description | |
---|---|---|
Read |
This method is called whenever the instance is required to deserialize itself.
(Inherited from GH_ISerializable.) | |
Redo |
Redo the action stored in this record.
| |
Undo |
Undo the action stored in this record.
| |
Write |
This method is called whenever the instance is required to serialize itself.
(Inherited from GH_ISerializable.) |