Click or drag to resize

GH_AnnotationBase Class

Represents an implementation of a Rhino annotation base class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooAnnotationBase
    Grasshopper.Kernel.TypesGH_GeometricGooAnnotationBase
      Grasshopper.Kernel.TypesGH_AnnotationBase
        Grasshopper.Kernel.TypesGH_Dimension
        Grasshopper.Kernel.TypesGH_Leader
        Grasshopper.Kernel.TypesGH_TextEntity

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_AnnotationBase : GH_GeometricGoo<AnnotationBase>, 
	IGH_PreviewData, IGH_BakeAwareData

The GH_AnnotationBase type exposes the following members.

Constructors
  NameDescription
Protected methodGH_AnnotationBase
Default constructor, creates an invalid annotation.
Protected methodGH_AnnotationBase(AnnotationBase)
Create a duplicate of an existing annotation.
Protected methodGH_AnnotationBase(GH_AnnotationBase)
Create a duplicate of another GH_AnnotationBase. This constructor also copies reference data.
Protected methodGH_AnnotationBase(Guid)
Create a new referenced annotation that references a Rhino dimension with the specified ID.
Protected methodGH_AnnotationBase(ObjRef)
Initializes a new instance of the GH_AnnotationBase class
Protected methodGH_AnnotationBase(AnnotationBase, ModelAnnotationStyle)
Create a duplicate of an existing annotation.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this annotation object. The annotation is considered to be loaded when the local annotation instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this dimension. If the dimension is referenced but cannot be loaded, then the dimension is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyStyle
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Protected propertyValueType
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the annotation is referenced, the local instance of the annotation is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodStatic memberCreateDisplay
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateAnnotation
Create a duplicate of this annotation.
Public methodDuplicateGeometry
Create a duplicate of this annotation.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodGetOverrides
Public methodLoadGeometry
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides GH_GeometricGooTLoadGeometry.)
Public methodLoadGeometry(RhinoDoc)
If the annotation is referenced and not yet loaded, attempts to load the leader.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodSetOverrides
Public methodToString
Format the dimension using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also