GH_ExpressionSyntaxWriter Class |
Namespace: Grasshopper.Kernel.Expressions
The GH_ExpressionSyntaxWriter type exposes the following members.
Name | Description | |
---|---|---|
RewriteAll |
Apply all syntax rulesets to the expression.
| |
RewriteForEvaluator(GH_CodeString) |
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars.
The expression will become less readable, do not let the user see the result of this function.
You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
| |
RewriteForEvaluator(String) |
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars.
The expression will become less readable, do not let the user see the result of this function.
You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
| |
RewriteForGraphicInterface(GH_CodeString) |
Rewrite the expression so that tags are replaced by the complex characters that make up
the esoteric operators, functions and constants. The expression should become more readable for humans.
| |
RewriteForGraphicInterface(String) |
Rewrite the expression so that tags are replaced by the complex characters that make up
the esoteric operators, functions and constants. The expression should become more readable
|