GH_PathOffset Class |
Namespace: Grasshopper.Kernel.Data
The GH_PathOffset type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_PathOffset | Initializes a new instance of the GH_PathOffset class |
![]() | GH_PathOffset(IEnumerableInt32) | Initializes a new instance of the GH_PathOffset class |
![]() | GH_PathOffset(IEnumerableInt32, Int32) | Initializes a new instance of the GH_PathOffset class |
![]() | GH_PathOffset(IEnumerableInt32, Int32, Boolean, Boolean) | Initializes a new instance of the GH_PathOffset class |
Name | Description | |
---|---|---|
![]() | ItemOffset |
Gets or sets the relative offset for branch items.
|
![]() | ItemWrap |
Gets or sets the ItemWrap flag.
|
![]() | PathOffset |
Gets access to the relative offsets for path indices.
|
![]() | PathWrap |
Gets or sets the PathWrap flag.
|
Name | Description | |
---|---|---|
![]() | OffsetPath(GH_Path, Int32, GH_Path, Int32) |
Offset a path + index value without wrapping.
|
![]() | OffsetPath(GH_Path, Int32, IGH_Structure, GH_Path, Int32) |
Offset a path + index value with wrapping and bounds checking.
|
![]() ![]() | ParseString | |
![]() | ToString |
Format the Path Offset.
(Overrides ObjectToString.) |