GH_IndexRange Structure |
Namespace: Grasshopper.Kernel.Data
The GH_IndexRange type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_IndexRange(Int32) |
Create a new singular range.
|
![]() | GH_IndexRange(Int32, Int32) |
Create a new range.
|
Name | Description | |
---|---|---|
![]() | Index0 |
Gets the first index in the range.
|
![]() | Index1 |
Gets the last index in the range.
|
![]() ![]() | InvalidRange |
Gets the predefined invalid range.
|
![]() | IsSingular |
Gets whether the range has zero length.
|
![]() | IsValid |
Gets whether this range is valid.
|
![]() | Length |
Gets the length of the range.
|
![]() ![]() | MaxValue |
Name | Description | |
---|---|---|
![]() | AdjacentTo |
Tests whether this range is adjacent to another.
|
![]() | Contains(GH_IndexRange) |
Tests whether a specified range is entirely contained within this range.
|
![]() | Contains(Int32) |
Tests whether a specified index is defined by this range.
|
![]() ![]() | Intersection |
Create the intersection between two ranges.
|
![]() | IntersectsWith |
Tests whether certain indices are described by both this and another range.
|
![]() ![]() | Split |
Split a range into two using an integer index.
|
![]() | ToString | (Overrides ValueTypeToString.) |
![]() ![]() | Union |
Create a range which contains both input ranges.
|