GH_Theme Class |
Namespace: Grasshopper.GUI.Theme
The GH_Theme type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Theme |
Create a new default theme.
|
![]() | GH_Theme(GH_Theme) |
Make a duplicate of another theme.
|
Name | Description | |
---|---|---|
![]() | BackGround |
Gets the theme background settings.
|
![]() ![]() | DefaultTheme | |
![]() | Objects |
Gets the theme objects and ZUI settings.
|
![]() | Page |
Gets the theme page and grid settings.
|
![]() | Palettes |
Gets the theme palette settings.
|
![]() | Wires |
Gets the theme wire settings.
|
Name | Description | |
---|---|---|
![]() | LoadTheme |
Instantiate all palette and gui defaults.
This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
|
![]() | Read | |
![]() | SaveTheme |
Store all palette and gui defaults.
This function writes the colour values out to grasshopper_gui.xml settings database.
|
![]() | Write |