GH_Grip Class |
Namespace: Grasshopper.GUI.Gradient
The GH_Grip type exposes the following members.
Name | Description | |
---|---|---|
GH_Grip | Initializes a new instance of the GH_Grip class | |
GH_Grip(GH_Grip) | Initializes a new instance of the GH_Grip class | |
GH_Grip(Double, Color) | Initializes a new instance of the GH_Grip class | |
GH_Grip(Double, Color, Color) | Initializes a new instance of the GH_Grip class |
Name | Description | |
---|---|---|
ColourLeft |
Gets the colour to the left of this grip.
| |
ColourRight |
Gets the colour to the right of this grip.
| |
GripId |
Gets the Grip ID.
| |
IsValid |
Gets whether this grip is valid. A valid grip must have a
non-empty Id and a non-NaN parameter.
| |
Parameter |
Gets or sets the numeric parameter of the grip.
| |
Selected |
Gets or sets whether this grip is selected.
Selection state is not (de)serialized.
| |
Type |
Gets whether the colour across this grip is smooth.
|