GH_WindowsFormUtil Class |
Namespace: Grasshopper.GUI
Name | Description | |
---|---|---|
![]() ![]() | CenterFormOnCursor(Form, Boolean) |
Positions a Form so that it is centered around the cursor
|
![]() ![]() | CenterFormOnCursor(Window, Boolean) |
Positions a Form so that it is centered around the cursor
|
![]() ![]() | CenterFormOnEditor(Form, Boolean) |
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden,
the form will be centered on the screen instead.
|
![]() ![]() | CenterFormOnEditor(Window, Boolean) |
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden,
the form will be centered on the screen instead.
|
![]() ![]() | CenterFormOnScreen(Form, Boolean) |
Positions a Form so that it is centered on the current screen.
The current screen being defined as the screen containing the cursor.
|
![]() ![]() | CenterFormOnScreen(Window, Boolean) |
Positions a Form so that it is centered on the current screen.
The current screen being defined as the screen containing the cursor.
|
![]() ![]() | CenterFormOnWindow(Form, Form, Boolean) |
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden,
the form will be centered on the screen instead.
|
![]() ![]() | CenterFormOnWindow(Window, Window, Boolean) |
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden,
the form will be centered on the screen instead.
|