GH_VerticalScrollBar Class |
Namespace: Grasshopper.GUI
The GH_VerticalScrollBar type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_VerticalScrollBar | Initializes a new instance of the GH_VerticalScrollBar class |
Name | Description | |
---|---|---|
![]() | Grip |
Gets the actual dimensions of the scroll bar grip.
|
![]() | GripRegion |
Gets the grip region for this scroll bar. The Grip Region is the area
in which the grip can be found. It is essentially the Client area minus the padding.
|
![]() | ImpliedVerticalOffset |
Gets or sets the offset of the target region as implied by the scroll ratio.
If you set this value, the ratio is reverse engineered.
|
![]() | ScreenHeight |
Gets or sets the height of the screen area (the visible area)
|
![]() | TargetHeight |
Gets or sets the height of the target area (the area being scrolled)
|
![]() | TargetRatio |
Gets or sets the scroll ration. If the scroll ratio is changed, the
OnScrollRatioChanged event will be raised.
|
Name | Description | |
---|---|---|
![]() | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).) |
![]() | OnPaintBackground | (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).) |
Name | Description | |
---|---|---|
![]() | ScrollRatioChanged |
Name | Description | |
---|---|---|
![]() | ToEto | (Defined by EtoExtensions.) |