GH_Slider_Obsolete Class |
Namespace: Grasshopper.GUI
The GH_Slider_Obsolete type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Slider_Obsolete | Initializes a new instance of the GH_Slider_Obsolete class |
Name | Description | |
---|---|---|
![]() | DisplayFormat |
Gets or sets the display format fo the slider. This is the formatting that is applied prior to drawing.
The default is {0} which results in a 1:1 display. Use this to append units or symbols.
|
![]() | DrawRail |
Gets or sets a flag that control whether or not grip rails are drawn.
|
![]() | GripBackColor |
Background colour of slider grip.
|
![]() | GripForeColor |
Foreground colour of slider grip.
|
![]() | IsIntermediate |
Gets the intermediate flag. If True, the user is currently dragging the slider.
|
![]() | Max |
Gets or sets the maximum allowed value.
|
![]() | Min |
Gets or sets the minimum allowed value.
|
![]() | NumericFormat |
Gets or sets the numeric format for the slider. This is the formatting that is applied to the number.
The default is #0.00 which results in a two digit rounding scheme.
|
![]() | TextInputMode |
Gets or sets the Text input mode for this slider.
|
![]() | TickFrequency |
Gets or sets the tick frequency of the slider.
|
![]() | Value |
Gets or sets the current value.
|
![]() | ValueF |
Gets or sets the current value in single-floating-point precision.
|
Name | Description | |
---|---|---|
![]() | Dispose | Releases the unmanaged resources used by the GH_Slider_Obsolete and optionally releases the managed resources (Overrides ContainerControlDispose(Boolean).) |
![]() | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).) |
![]() | OnPaintBackground | (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).) |
![]() | OnValueChanged |
Raise the ValueChanged event
|
![]() ![]() | SendMessage |
Name | Description | |
---|---|---|
![]() | ValueChanged |
Raised whenever the value of the slider is changed via GUI interaction.
|
Name | Description | |
---|---|---|
![]() | ToEto | (Defined by EtoExtensions.) |