GH_MenuTextBox Class |
Namespace: Grasshopper.GUI
The GH_MenuTextBox type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_MenuTextBox |
Constructor for TextBox collection.
|
Name | Description | |
---|---|---|
![]() | OriginalText |
Gets or sets the original text that was visible when the control was first displayed.
|
![]() | Text |
Gets or sets the current text.
|
![]() | TextBoxItem |
Gets the text box control embedded in the menu.
|
![]() | Width |
Gets or sets the width of the control.
|
Name | Description | |
---|---|---|
![]() | CloseEntireMenuStructure |
Call this function to close the ENTIRE menu structure.
|
Name | Description | |
---|---|---|
![]() | KeyDown |
Raised whenever a key is pressed.
|
![]() | TextChanged |
Raised whenever the text in the textbox changes.
|