GH_MaterialPreviewControl Class |
Namespace: Grasshopper.GUI
The GH_MaterialPreviewControl type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_MaterialPreviewControl | Initializes a new instance of the GH_MaterialPreviewControl class |
Name | Description | |
---|---|---|
![]() | Colour |
Gets or sets the colour of this preview.
|
![]() | Selected |
Gets or sets the Selected state of this preview. Selected previews have thick borders drawn around them.
|
![]() | SelectOnClick |
Gets or sets whether this control can be selected.
|
Name | Description | |
---|---|---|
![]() | Dispose | Releases the unmanaged resources used by the GH_MaterialPreviewControl and optionally releases the managed resources (Overrides ContainerControlDispose(Boolean).) |
Name | Description | |
---|---|---|
![]() | ColourChanged | |
![]() | MaterialImagePostPaint | |
![]() | SelectedChanged |
Name | Description | |
---|---|---|
![]() | ToEto | (Defined by EtoExtensions.) |