GH_GDI_Util Class |
Namespace: Grasshopper.GUI
The GH_GDI_Util type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | BoxUnion |
Create the outline of a set of boxes.
|
![]() ![]() | FilletBoxOutline |
Fillet all the corners of the combined outline of a set of rectangles.
|
![]() ![]() | FilletPolyline(Point, Int32) |
Fillet all the corners of a freeform outline.
|
![]() ![]() | FilletPolyline(PointF, Single) |
Fillet all the corners of a freeform outline.
|
![]() ![]() | FilletRectangle |
Create a rectangle with filleted corners.
|
![]() ![]() | Freeform_Blob(IEnumerableRectangleF, Int32, Double) |
Create a meta-ball outline for a set of rectangles.
|
![]() ![]() | Freeform_Blob(IEnumerableRectangleF, Int32, Double, FieldSolver, Double) |
Create a meta-ball outline for a set of rectangles.
|
![]() ![]() | SimplifyBoxes |
Create a simplified collection of Rectangles that describe the same union space as the supplied rectangles.
|