GH_FontList Class |
Namespace: Grasshopper.GUI
The GH_FontList type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_FontList | Initializes a new instance of the GH_FontList class |
Name | Description | |
---|---|---|
![]() | DisplayText |
Gets or sets the placeholder string.
|
![]() | Filter |
Gets or sets the filter string.
You must call RecreateFontList() before the new font list is created.
|
![]() | FontFamily |
Gets or sets the selected font family.
|
![]() | FontSize |
Gets or sets the font size.
|
![]() | FontStyle |
Gets or sets the font style for all families.
|
Name | Description | |
---|---|---|
![]() | CreateFont |
Create a font that best approximates the current settings.
|
![]() | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).) |
![]() | OnPaintBackground | (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).) |
![]() | RecreateFontList |
Name | Description | |
---|---|---|
![]() | ToEto | (Defined by EtoExtensions.) |