GH_DigitScroller Class |
Namespace: Grasshopper.GUI
The GH_DigitScroller type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_DigitScroller | Initializes a new instance of the GH_DigitScroller class |
Name | Description | |
---|---|---|
![]() | AllowRadixDrag |
Gets or sets whether the radix symbol can be dragged.
|
![]() | AllowTextInput |
Gets or sets whether the control accepts text input override.
|
![]() | Amplify |
Gets or sets whether vertical mouse movement ought to be amplified.
|
![]() | DecimalPlaces |
Gets or sets the number of decimal places.
|
![]() | DigitAlign |
Gets or sets the digit align mode
|
![]() | Digits |
Gets or sets the number of digits displayed in the scroller.
|
![]() | DigitScroller |
Gets the internal scroller object.
|
![]() | Epsilon |
Gets the smallest possible change with the current settings.
|
![]() | MaximumValue |
Gets or sets the upper bound of the scroll value.
|
![]() | MinimumValue |
Gets or sets the lower bound of the scroll value.
|
![]() | Prefix |
Gets or sets the prefix text
|
![]() | Radix |
Gets or sets the radix point index.
|
![]() | Suffix |
Gets or sets the prefix text
|
![]() | Value |
Gets or sets the value of this scroller.
|
Name | Description | |
---|---|---|
![]() | Input_Assign | (Overrides GH_TextInputBaseControl.Input_Assign(String).) |
![]() | Input_Parse | (Overrides GH_TextInputBaseControl.Input_Parse(String).) |
![]() | Input_Supply | (Overrides GH_TextInputBaseControl.Input_Supply.) |
![]() | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).) |
![]() | OnPaintBackground | (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).) |
Name | Description | |
---|---|---|
![]() | ValueChanged |
Name | Description | |
---|---|---|
![]() | ToEto | (Defined by EtoExtensions.) |