GH_ColourPicker Class |
Namespace: Grasshopper.GUI
The GH_ColourPicker type exposes the following members.
Name | Description | |
---|---|---|
GH_ColourPicker | Initializes a new instance of the GH_ColourPicker class |
Name | Description | |
---|---|---|
AllowNumericInput |
Gets or sets whether this colour picker pops up a textbox on channel slider double clicks.
| |
Colour |
Gets or sets the colour currently specified in the picker.
| |
DesiredHeight |
Gets the ideal height for this control given the current width and UI settings.
| |
ShowAlphaSlider |
Gets or sets whether the alpha channel slider is included.
| |
ShowChannelSliders |
Gets or sets whether the channel sliders are included.
|
Name | Description | |
---|---|---|
Dispose | Releases the unmanaged resources used by the GH_ColourPicker and optionally releases the managed resources (Overrides ContainerControlDispose(Boolean).) | |
OnPaint | (Overrides ControlOnPaint(PaintEventArgs).) | |
OnPaintBackground | (Overrides ScrollableControlOnPaintBackground(PaintEventArgs).) |
Name | Description | |
---|---|---|
ColourChanged |
Raised whenever the value of the slider is changed via GUI interaction.
|
Name | Description | |
---|---|---|
ToEto | (Defined by EtoExtensions.) |