GH_CanvasMouseEvent Class |
Namespace: Grasshopper.GUI
The GH_CanvasMouseEvent type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_CanvasMouseEvent |
Blank constructor.
|
![]() | GH_CanvasMouseEvent(GH_Viewport, MouseEventArgs) |
Constructor.
|
![]() | GH_CanvasMouseEvent(Point, PointF, MouseButtons, Int32, Int32) |
Constructor.
|
Name | Description | |
---|---|---|
![]() | Button |
Gets which mouse button was pressed.
|
![]() | CanvasLocation |
Gets the location of the cursor in canvas unit coordinates.
|
![]() | CanvasX |
Gets the x-coordinate of the cursor location in canvas unit coordinates.
|
![]() | CanvasY |
Gets the y-coordinate of the cursor location in canvas unit coordinates.
|
![]() | Clicks |
Gets the number of times the mouse button was pressed and released.
|
![]() | ControlLocation |
Gets the location of the cursor in control pixel coordinates.
|
![]() | ControlX |
Gets the x-coordinate of the cursor location in control pixel coordinates.
|
![]() | ControlY |
Gets the y-coordinate of the cursor location in control pixel coordinates.
|
![]() | Delta |
Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
|
![]() | WinFormsEventArgs |
Downcast this data into a Windows.Forms.MouseEventArgs instance.
|