GH_AsynchFileData Class |
Namespace: Grasshopper.GUI
The GH_AsynchFileData type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_AsynchFileData |
Asynchronous constructor. File properties will be loaded asychronously.
|
Name | Description | |
---|---|---|
![]() | Callback |
Gets or sets the callback delegate to be used when properties are updated.
|
![]() | FileCreated |
Gets the date at which the file was created.
|
![]() | FileExists |
Gets whether the file exists.
Note that this property returns false if DataExists=False, regardless of whether the file exists.
|
![]() | FileLastChanged |
Gets the date at which the file was last changed.
|
![]() | FileSize |
Gets the size of the file.
|
![]() | FileThumbnail |
Gets the thumbnail bitmap associated with the file.
|
![]() | HarvestThumbnail |
Gets or sets whether the thumbnail ought to be parsed.
At the moment this only makes sense for GH/GHX files.
|
![]() | IsFileData |
Gets whether the data has been retrieved at least once.
|
Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the GH_AsynchFileData |
![]() | UpdateProperties |
Updates all file properties on the thread on which this method is called.
|
Name | Description | |
---|---|---|
![]() | FilePath |
Gets the location this instance is watching.
|
![]() | IsLocal |
Gets whether Grasshopper thinks the file it is watching is on a local machine.
|