GH_PaletteStyle Class |
Namespace: Grasshopper.GUI.Canvas
The GH_PaletteStyle type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_PaletteStyle(Color) |
Construct a new GH_Box_Palette_Colours instance with a single base colour.
|
![]() | GH_PaletteStyle(Color, Color) |
Construct a new GH_Box_Palette_Colours instance.
|
![]() | GH_PaletteStyle(Color, Color, Color) |
Construct a new GH_Box_Palette_Colours instance.
|
Name | Description | |
---|---|---|
![]() | Edge |
Gets or sets the edge of this style.
|
![]() | Fill |
Gets or sets the fill of this style.
|
![]() | Text |
Gets or sets the text of this style.
|
Name | Description | |
---|---|---|
![]() | CreateBrush |
Create a fill brush. At low zoom levels the brush will be solid colour,
at medium to high zoom levels the brush will have a gradient.
|