GH_NamedView Class |
Namespace: Grasshopper.GUI.Canvas
The GH_NamedView type exposes the following members.
Name | Description | |
---|---|---|
GH_NamedView |
Create a default named view.
| |
GH_NamedView(Rectangle, RectangleF) |
Create a new view useful for box-fit transitions.
| |
GH_NamedView(GH_Viewport, Point, PointF) |
Create a new view useful for point match transitions.
| |
GH_NamedView(GH_Viewport, Rectangle, PointF) |
Create a new view useful for point inclusion transitions.
| |
GH_NamedView(String, PointF, Single, GH_NamedViewType) |
Create a new named view.
|
Name | Description | |
---|---|---|
Name |
Gets or sets the name of the view.
| |
Point |
Gets or sets the anchor point of the named view.
| |
Type |
Gets or sets a value indicating whether the anchor point represents the target or the center.
| |
Zoom |
Gets or sets the zoom factor of the named view.
|
Name | Description | |
---|---|---|
LoadFromViewport |
Create a named view from a viewport.
| |
Read | ||
SetToViewport(GH_Canvas) |
Set the named view to the canvas viewport and redraw the canvas.
| |
SetToViewport(GH_Viewport) |
Set the named view to a viewport.
| |
SetToViewport(GH_Canvas, Int32) |
Animates a view transition.
| |
Write |
Name | Description | |
---|---|---|
SmoothFrame |
This event is raised during smooth animations.
|