GH_DocDiagramPainter Class |
Namespace: Grasshopper.GUI.Canvas
The GH_DocDiagramPainter type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_DocDiagramPainter | Initializes a new instance of the GH_DocDiagramPainter class |
Name | Description | |
---|---|---|
![]() | BoundingBox |
Gets the 2D domain of the diagram in canvas coordinates.
|
![]() | DrawingBox |
Gets the 2D domain of the diagram in image coordinates.
|
![]() | IgnoreSelectedStates |
Gets or sets the Ignore Selected State flag. When set to True,
selected objects are not drawn in a different colour.
|
![]() | Image |
Gets the diagram image (only available after a call to PaintDiagram().
|
![]() | Size |
Gets the width and height (in pixels) of this diagram image.
|
![]() | Zoom |
Gets the zoom factor for this diagram.
|
Name | Description | |
---|---|---|
![]() | MapPoint(Point) | |
![]() | MapPoint(PointF) | |
![]() | MapRectangle | |
![]() | MapX(Int32) | |
![]() | MapX(Single) | |
![]() | MapY(Int32) | |
![]() | MapY(Single) | |
![]() | PaintDiagram(IEnumerableIGH_DocumentObject, Int32, Int32) |
Paint a diagram of a document.
|
![]() | PaintDiagram(IEnumerableIGH_DocumentObject, Int32, Int32, Int32) |
Paint a diagram of a document.
|
![]() | UnmapPoint | |
![]() | UnmapRectangle | |
![]() | UnmapX | |
![]() | UnmapY |