GH_CanvasGH_ImageSettings Class |
Namespace: Grasshopper.GUI.Canvas
The GH_CanvasGH_ImageSettings type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_CanvasGH_ImageSettings |
Create a new instance of the GH_ImageSettings class with default values.
|
![]() | GH_CanvasGH_ImageSettings(String) |
Create a new instance of the GH_ImageSettings class.
|
![]() | GH_CanvasGH_ImageSettings(String, String, String) |
Create a new instance of the GH_ImageSettings class.
|
Name | Description | |
---|---|---|
![]() | BackColour |
Gets or sets the background colour to use for the high-resolution rendering.
|
![]() | Extension |
Gets or sets the image extension of the target image.
|
![]() | FileName |
Gets or sets the filename of the target image.
|
![]() | Folder |
Gets or sets the folder in which the target image will be saved.
|
![]() ![]() | TileSize |
Gets the default tile size for high-resolution export. This is a constant value.
|
![]() | Zoom |
Gets or sets the zoom at which to export the high-resolution image.
|