GH_TextBoxInputBase Class |
Namespace: Grasshopper.GUI.Base
The GH_TextBoxInputBase type exposes the following members.
Name | Description | |
---|---|---|
GH_TextBoxInputBase | Initializes a new instance of the GH_TextBoxInputBase class |
Name | Description | |
---|---|---|
Font |
Gets or sets the Font to use in this control.
| |
IsTextInput |
Gets whether the text input box is currently on screen.
|
Name | Description | |
---|---|---|
HandleTextInputAccepted | ||
HideTextInputBox |
Hides the text-input override form (if it is displayed).
| |
RespondToEnter | ||
RespondToEscape | ||
ShowTextInputBox(Control, String, Boolean) |
Display a floating text-box on top of the owner control.
| |
ShowTextInputBox(Control, String, Boolean, Boolean) |
Display a floating text-box on top of the owner control.
| |
ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) |
Display a floating text-box on top of the owner control.
|