IGH_Param Properties |
The IGH_Param type exposes the following members.
Name | Description | |
---|---|---|
Access |
Gets or sets the Access level for this parameter.
| |
DataMapping |
Gets or sets the data mapping of this Parameter.
| |
DataType |
Gets the type of the current data state.
| |
HasProxySources |
Gets a value indicating whether or not this parameter maintains proxy sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
IsDataProvider |
Gets whether or not this object is capable of emitting data.
(Inherited from IGH_ActiveObject.) | |
Kind |
Gets the parameter kind. The kind is evaluated lazily and cached.
| |
Locked |
Gets or sets the locked flag of this object. Locked objects are ignored during solutions.
(Inherited from IGH_ActiveObject.) | |
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
The default is TRUE.
(Inherited from IGH_ActiveObject.) | |
Optional |
Gets or sets whether or not this parameter is considered optional by the owner component.
Empty, non-optional parameters prevent the component from being solved.
| |
Phase |
Gets the solution phase in which this object is currently stuck.
(Inherited from IGH_ActiveObject.) | |
ProcessorTime |
Gets the most recent measured processor time.
(Inherited from IGH_ActiveObject.) | |
ProxySourceCount |
Gets the number of proxy sources for this parameter.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
Recipients |
Gets a list of all the recipients of this parameter.
I.e. a recipient has this parameter as one of the sources.
The Recipient list is maintained by the parameter,
do not modify it yourself.
| |
Reverse |
Gets or sets the data reverse modifier of this parameter.
| |
RuntimeMessageLevel |
Gets the worst-case level of all messages. I.e. if only warnings have been recorded,
the level will be ::warning. If even a single error exists, the level will be ::error.
(Inherited from IGH_ActiveObject.) | |
Simplify |
Gets or sets the simplify modifier for this parameter.
| |
SourceCount |
Gets the number of sources for this parameter.
| |
Sources |
Gets a list of source parameters. Do not modify this list,
if you wish to add or remove sources, use dedicated functions
like AddSource() and RemoveSource instead.
| |
StateTags |
Gets all the StateTags that are associated with this parameter.
A state tag is a visual feedback icon that represents specific internal settings.
| |
Type |
Gets the Framework Type descriptor for the stored Data.
| |
TypeName |
Gets a human readable description of the data stored in this parameter.
| |
VolatileData |
Gets the instance of the volatile data tree stored in this parameter.
| |
VolatileDataCount |
Gets the total number of volatile data items stored in this parameter.
| |
WireDisplay |
Gets or sets the wire display style for this parameter.
Wire display only affects the wires connected to the parameter input.
|