GH_ActiveObject Properties |
The GH_ActiveObject type exposes the following members.
Name | Description | |
---|---|---|
ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
Exposure |
Gets the exposure of this object in the Graphical User Interface.
Icon |
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached,
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
and return False.
InstanceDescription |
Gets a description of the current state of the object.
IsDataProvider |
Returns a boolean indicating whether or not the current object can seed data.
Locked |
Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
| |
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
The default is TRUE.
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
Phase |
Gets or sets the solution phase this object is currenly in.
| |
ProcessorTime |
Gets the most recent processor time profiler value.
| |
RuntimeMessageLevel |
Returns the worst case flag for the current object