IGH_Param Methods |
The IGH_Param type exposes the following members.
Name | Description | |
---|---|---|
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
Sources provide this parameter with data at runtime.
| |
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
Sources provide this parameter with data at runtime.
| |
AddVolatileData |
Inserts an item of volatile data into the data structure.
| |
AddVolatileDataList |
Inserts a list of items into the data structure.
| |
AddVolatileDataTree |
Insert an entire data tree into this parameter.
| |
ClearData |
This function is called whenever the object needs to
clear all solution data. This usually amounts to wiping volatile caches and messages.
This function will not affect any other objects, but it will set the Phase flag to
ClearProxySources |
Remove all proxy sources without attempting to relink them.
CollectData |
This function is called whenever the object is required to collect
all data. Either from Persistent records, from source params or whatever.
This step is only performed if the phase flag is Blank or Failed.
ComputeData |
This function is called whenever the object is required to generate new data.
This step is only performed by some objects and only when the Phase flag is Collected.
Upon completion, the Phase will be Computed. If this object throws exceptions,
CreateProxySources |
Convert all proper source parameters into proxy sources.
RegisterRemoteIDs |
If this object depends on Rhino Objects, you must register the UUIDs of those objects.
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
RemoveAllSources |
Remove all sources from this parameter.
| |
RemoveEffects |
Remove all post-process effects.
| |
RemoveSource(Guid) |
Remove the specified source from this parameter.
| |
RemoveSource(IGH_Param) |
Remove the specified source from this parameter.
| |
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
does not exist in this parameter, nothing happens.
| |
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
does not exist in this parameter, nothing happens.