Click or drag to resize

GH_FileWatcher Methods

Methods
  NameDescription
Public methodStatic memberCreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcherFileChanged)
Create a new FileSystem Watcher object aimed at a specific file.
Public methodStatic memberCreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcherFileChangedSimple)
Create a new FileSystem Watcher object aimed at a specific file.
Public methodStatic memberCreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcherFileChanged)
Create a new FileSystem Watcher object aimed at a specific file.
Public methodStatic memberCreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcherFileChangedSimple)
Create a new FileSystem Watcher object aimed at a specific file.
Public methodDispose
Protected methodDispose(Boolean)
Public methodSetCustomUIThread(Control)
If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.
Public methodSetCustomUIThread(Form)
If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.
Top
See Also