GH_ComponentGH_InputParamManagerAddParameter Method (IGH_Param) |
Generic parameter addition. If you cannot use one of the utility methods provided
by this class, you can register a customized parameter using this method.
Namespace:
Grasshopper.Kernel
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public int AddParameter(
IGH_Param param
)
Public Function AddParameter (
param As IGH_Param
) As Integer
Parameters
- param
- Type: Grasshopper.KernelIGH_Param
The parameter to add.
Return Value
Type:
Int32Index of the newly added parameter.
See Also