Grasshopper API
Grasshopper API
Grasshopper.Kernel.Expressions
GH_ExpressionParser Class
GH_ExpressionParser Methods
AddVariable Method
AddVariableEx Method
BalancedCharTest Method
CachedSymbols Method
CacheSymbols Method
ClearSymbols Method
ClearVariables Method
DisplayFunctionList Method
Evaluate Method
IsValidVariableName Method
Op_BinaryAddition Method
Op_BinaryAmpersand Method
Op_BinaryAND Method
Op_BinaryAngle Method
Op_BinaryCircumflex Method
Op_BinaryCrossProduct Method
Op_BinaryDistance Method
Op_BinaryDivision Method
Op_BinaryEquality Method
Op_BinaryIntegerDivision Method
Op_BinaryLargerThan Method
Op_BinaryLargerThanOrEqual Method
Op_BinaryModulus Method
Op_BinaryMultiplication Method
Op_BinaryNearEquality Method
Op_BinaryOR Method
Op_BinaryPull Method
Op_BinaryPush Method
Op_BinarySmallerThan Method
Op_BinarySmallerThanOrEqual Method
Op_BinarySubtraction Method
Op_BinaryXOR Method
Op_UnaryBang Method
Op_UnaryCube Method
Op_UnaryDeg2Rad Method
Op_UnaryImaginary Method
Op_UnaryMinus Method
Op_UnaryNOT Method
Op_UnaryOComponent Method
Op_UnaryPlus Method
Op_UnarySquare Method
Op_UnaryXComponent Method
Op_UnaryYComponent Method
Op_UnaryZComponent Method
GH_ExpressionParser
ClearSymbols Method
Destroy the Symbols cache.
Namespace:
Grasshopper.Kernel.Expressions
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax
C#
VB
Copy
public
void
ClearSymbols
()
Public
Sub
ClearSymbols
See Also
Reference
GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace
Grasshopper for Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com