Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
ON_SubDSectorIterator Member List
This is the complete list of members for
ON_SubDSectorIterator
, including all inherited members.
CenterVertex
() const
ON_SubDSectorIterator
CurrentEdge
(unsigned int face_side_index) const
ON_SubDSectorIterator
CurrentEdgeDirection
(unsigned int face_side_index) const
ON_SubDSectorIterator
CurrentEdgePtr
(unsigned int face_side_index) const
ON_SubDSectorIterator
CurrentEdgeRingVertex
(unsigned int face_side_index) const
ON_SubDSectorIterator
CurrentFace
() const
ON_SubDSectorIterator
CurrentFaceCenterVertexIndex
() const
ON_SubDSectorIterator
CurrentFaceDirection
() const
ON_SubDSectorIterator
CurrentFacePtr
() const
ON_SubDSectorIterator
CurrentRingIndex
() const
ON_SubDSectorIterator
Empty
ON_SubDSectorIterator
static
FirstFace
()
ON_SubDSectorIterator
IncrementFace
(int increment_direction, ON_SubDSectorIterator::StopAt stop_at)
ON_SubDSectorIterator
IncrementToCrease
(int increment_direction)
ON_SubDSectorIterator
IncrementToCrease
(int increment_direction, unsigned *increment_count)
ON_SubDSectorIterator
InitialFace
() const
ON_SubDSectorIterator
InitialFaceCenterVertexIndex
() const
ON_SubDSectorIterator
Initialize
(const ON_SubDVertex *center_vertex)
ON_SubDSectorIterator
Initialize
(const ON_SubDFace *initial_face, ON__UINT_PTR iterator_orientation, const ON_SubDVertex *center_vertex)
ON_SubDSectorIterator
Initialize
(const ON_SubDFace *initial_face, ON__UINT_PTR iterator_orientation, unsigned int face_vertex_index)
ON_SubDSectorIterator
Initialize
()
ON_SubDSectorIterator
InitializeToCurrentFace
()
ON_SubDSectorIterator
IsValid
() const
ON_SubDSectorIterator
NextFace
(ON_SubDSectorIterator::StopAt stop_at)
ON_SubDSectorIterator
ON_SubDSectorIterator
()=default
ON_SubDSectorIterator
ON_SubDSectorIterator
(const ON_SubDSectorIterator &)=default
ON_SubDSectorIterator
operator=
(const ON_SubDSectorIterator &)=default
ON_SubDSectorIterator
PrevFace
(ON_SubDSectorIterator::StopAt stop_at)
ON_SubDSectorIterator
StopAt
enum name
ON_SubDSectorIterator
~ON_SubDSectorIterator
()=default
ON_SubDSectorIterator
Generated on Wed Mar 12 2025 13:56:30 for Rhino C++ API by
1.8.17