Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
ON_SubDMeshFragmentGrid Member List
This is the complete list of members for
ON_SubDMeshFragmentGrid
, including all inherited members.
DisplayDensity
() const
ON_SubDMeshFragmentGrid
DisplayDensityReduction
() const
ON_SubDMeshFragmentGrid
Empty
ON_SubDMeshFragmentGrid
static
GetGridParameters
(unsigned int grid_point_index, double grid_parameters[2]) const
ON_SubDMeshFragmentGrid
Grid2dexFromPointIndex
(unsigned int grid_point_index) const
ON_SubDMeshFragmentGrid
GridFaceCount
() const
ON_SubDMeshFragmentGrid
GridId
() const
ON_SubDMeshFragmentGrid
GridPointCount
() const
ON_SubDMeshFragmentGrid
LevelOfDetail
() const
ON_SubDMeshFragmentGrid
m_F
ON_SubDMeshFragmentGrid
m_F_count
ON_SubDMeshFragmentGrid
m_F_level_of_detail
ON_SubDMeshFragmentGrid
m_F_stride
ON_SubDMeshFragmentGrid
m_next_level_of_detail
ON_SubDMeshFragmentGrid
m_prev_level_of_detail
ON_SubDMeshFragmentGrid
m_S
ON_SubDMeshFragmentGrid
m_side_segment_count
ON_SubDMeshFragmentGrid
OneQuadGrid
ON_SubDMeshFragmentGrid
static
PointIndexFromGrid2dex
(unsigned int i, unsigned int j) const
ON_SubDMeshFragmentGrid
QuadGridFromDisplayDensity
(unsigned int display_density, unsigned int mesh_density_reduction)
ON_SubDMeshFragmentGrid
static
QuadGridFromSideSegmentCount
(unsigned int side_segment_count, unsigned int mesh_density_reduction)
ON_SubDMeshFragmentGrid
static
SidePointCount
() const
ON_SubDMeshFragmentGrid
SideSegmentCount
() const
ON_SubDMeshFragmentGrid
Generated on Wed Mar 12 2025 13:56:30 for Rhino C++ API by
1.8.17