Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
ON_3dmAnnotationSettings Member List
This is the complete list of members for
ON_3dmAnnotationSettings
, including all inherited members.
Default
ON_3dmAnnotationSettings
static
DimensionLayerId
() const
ON_3dmAnnotationSettings
Dump
(ON_TextLog &text_log) const
ON_3dmAnnotationSettings
Enable_V5_AnnotationScaling
(bool bEnable)
ON_3dmAnnotationSettings
EnableHatchScaling
(bool bEnable)
ON_3dmAnnotationSettings
EnableLayoutSpaceAnnotationScaling
(bool bEnable)
ON_3dmAnnotationSettings
EnableModelSpaceAnnotationScaling
(bool bEnable)
ON_3dmAnnotationSettings
EnableUseDimensionLayer
(bool bEnable)
ON_3dmAnnotationSettings
Is_V5_AnnotationScalingEnabled
() const
ON_3dmAnnotationSettings
IsHatchScalingEnabled
() const
ON_3dmAnnotationSettings
IsLayoutSpaceAnnotationScalingEnabled
() const
ON_3dmAnnotationSettings
IsModelSpaceAnnotationScalingEnabled
() const
ON_3dmAnnotationSettings
m_angleformat
ON_3dmAnnotationSettings
m_angularunits
ON_3dmAnnotationSettings
m_arrowlength
ON_3dmAnnotationSettings
m_arrowtype
ON_3dmAnnotationSettings
m_arrowwidth
ON_3dmAnnotationSettings
m_centermark
ON_3dmAnnotationSettings
m_dimexe
ON_3dmAnnotationSettings
m_dimexo
ON_3dmAnnotationSettings
m_dimscale
ON_3dmAnnotationSettings
m_dimunits
ON_3dmAnnotationSettings
m_facename
ON_3dmAnnotationSettings
m_lengthformat
ON_3dmAnnotationSettings
m_resolution
ON_3dmAnnotationSettings
m_textheight
ON_3dmAnnotationSettings
ON_3dmAnnotationSettings
()=default
ON_3dmAnnotationSettings
ON_3dmAnnotationSettings
(const ON_3dmAnnotationSettings &)
ON_3dmAnnotationSettings
operator=
(const ON_3dmAnnotationSettings &)
ON_3dmAnnotationSettings
Read
(ON_BinaryArchive &)
ON_3dmAnnotationSettings
SetDimensionLayerId
(const ON_UUID &dimension_layer_id)
ON_3dmAnnotationSettings
SetWorldViewHatchScale
(double world_view_hatch_scale)
ON_3dmAnnotationSettings
SetWorldViewTextScale
(double world_view_text_scale)
ON_3dmAnnotationSettings
UseDimensionLayer
() const
ON_3dmAnnotationSettings
WorldViewHatchScale
() const
ON_3dmAnnotationSettings
WorldViewTextScale
() const
ON_3dmAnnotationSettings
Write
(ON_BinaryArchive &) const
ON_3dmAnnotationSettings
~ON_3dmAnnotationSettings
()
ON_3dmAnnotationSettings
Generated on Wed Mar 12 2025 13:56:17 for Rhino C++ API by
1.8.17